VERIFIED SOLUTION i

Date values in Portrait Dialogue appear to be shown in the wrong regional format

Issue

There seems to be an inconsistency in how date values are handled in Portrait Dialogue (6.0.1).
A database date field with the value of "01-09-2011 17:00:00" is handled as follows:

Original value in database: 01-09-2011 17:00:00
Preview data and values in PD selections: 01-09-2011 17:00:00
Merge in email templates: 9/1/2011 5:00:00 PM
Customer View: 9/1/2011 5:00:00 PM

The region and time settings for both the Application and Database servers are set to Danish/Denmark etc. in the operating system.

 

Cause

Visual Dialogue gets its language/region settings from client PC Windows configuration.  
So, the region and time settings for both the Application and/or Database servers may be set to the incorrect culture and/or language.  

The formatting of dates in merge fields will follow the regional settings of the Dialogue Server, or more precisely, the settings of the windows user session under which the COM+ application is running.
So, the culture settings for that user may be incorrect.

 

Resolution

UPDATED: August 16, 2018
This has been reported for users who connect to Dialogue with Citrix.  It is up to the Citrix administrators to make sure the login to a Citrix session has the correct language/region settings.
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Otherwise, the language/region settings used in Visual Dialogue, and of course, in a browser, will be the language/region settings configured on the computer running the Browser, or Visual Dialogue.
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The formatting of dates in merge fields will follow the regional settings of the Dialogue Server, or more precisely, the settings of the windows user session under which the COM+ application is running.
Here are the steps necessary to make the change:
  1. First open the Component Services, and locate the MH Dialogue Server COM+ application
  2. Open the Properties for the MH Dialogue Server COM+ application, and go to the identity tab.
  3. Look and see what user the COM+ is running as.
    1.  Let's say the COM+ is running as a user called "MHSysUser"
  4. Next, log into the application server as the MHSysUser user.
  5. As the MHSysUser user, go to the region settings in the control panel. 
    1. You may have to go to "Additional settings..."
  6. Change the necessary region settings for the MHSysUser user.  
  7. Log off the server as that user
  8. Restart the com+ and restart the instance in Dialogue Admin.
  9. Test.
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The web.config file for each of the PD web apps can be checked to see if the correct Globalisation settings are made.
For UK it should look like this:
<globalization culture="en-GB" requestEncoding="utf-8" responseEncoding="utf-8" uiCulture="en-GB"></globalization>
These can be set in IIS, in the ASP.NET section, in the .NET Globalization settings for Culture.