VERIFIED SOLUTION i

"Serial number is invalid" or "Access Code is invalid" error encountered during activation process in MapInfo Pro

Issue

When trying to activate MapInfo Pro, users may see error messages such as  'Serial number <serial here>  is invalid' or 'Access Code <access code here>  is invalid".

Cause

This error message most often occurs due to
1) the user entering an incorrect number
or
2) the user is copying and pasting in the number and is mistakenly copying in a "null" character or empty space at the beginning or end of the string.

Resolution

UPDATED: January 16, 2019
To resolve this issue, try clearing the entered numbers and carefully enter the numbers manually  - do not copy and paste.
 
Environment Details
Products affected: MapInfo Pro.