VERIFIED SOLUTION i
X

Resolve CODE-1 Plus database incompatible error message

Issue

Upgrading or reverting back from the latest software version, CODE-1 Plus may encounter database incompatibility errors:

Example 1:
CODE-1 Plus version 3.6 compatible with version 2.9-3.8 database versions.

Encountered error:
CODE-1 PLUS ERROR:  02.9 IS NOT COMPATIBLE WITH SOFTWARE VERSION 03.6.

Example 2:
CODE-1 Plus version 4.0 compatible with version 4.0 database:

Encountered error:
CODE-1 PLUS ERROR:  04.0 IS NOT COMPATIBLE WITH SOFTWARE VERSION 04.0

Cause

Mixed modules of software versions in the installed software libraries will result in the encountered incompatibility errors.

Resolution

UPDATED: April 21, 2017


Resolutions:

1)  Re-install product
2)  remove old modules of prior version from the currently used libraries
3)  Mainframe JCL - make sure correct libraries are upfront in the concatenations.

Environment Details

Products affected: z/OS, HPUX, AIX, Solaris, Linux, Windows
 

Downloads

  • No Downloads