VERIFIED SOLUTION i
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Resolving MapInfo Pro MSVCR120.dll errors at startup

Issue

At launch, MapInfo Pro displays an MSVCR120.dll error:
User-added image

MapInfow.exe - Bad Image

C:\Windows\system32\MSVCR120.dll is either not designed to run on Windows or it contains an error. Try installing the program again using the original installation media or contact your system administrator or the software vendor for support.

Cause

 
This issue is typically caused by the .dll being corrupt or incomplete, which could be due to running the Pro setup.exe without administrative privileges. 

Note that the dll referenced in this error is version-specific.
Different versions of MapInfo Pro install different C++ libraries and different .dll's.

Resolution

UPDATED: September 12, 2018


 
  1. Uninstall MI Pro (do not transfer license if prompted) 
  2. Manually replace the DLL
    • Remove MSVCR120.dll from c:\Windows\System32\MSVCR120.dll 
    • Download and install Visual C++ Redistributable Packages for Visual Studio 2013
    • Restart the Windows machine 
Download link for C++ 2013 library is: http://www.microsoft.com/en-us/download/details.aspx?id=40784

3. Have a user with local machine admin rights run the MapInfo Professional setup.exe installer with admin privileges. ( also Right-Click and Run As Administrator )

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Additional solutions offered by Engineering:

The error is implying that either the 32-bit version of the file got installed in the 64-bit directory OR that the MSVCR120.dll installed is corrupt. How either one of these issues came about is the interesting question. Possible suggestions are:

1. An improperly authored transform was applied to MapInfo Professional when it was installed and it is installing either the wrong bit version or a corrupt version of MSVCR120.dll.
2. An improperly authored transform was applied to some other product when it was installed in that environment and it is installing either the wrong bit version or a corrupt version of MSVCR120.dll.
3. Another piece of software was installed and it is causing the issue.
4. A virus has gotten onto the system and corrupted the operating system.

In case of #1, uninstall MapInfo Pro and reinstall without the transform (Engineering does not support customers who use/apply transforms to the Pro installer. It is a violation of the license agreement).

In case of #2, uninstall the other product and reinstall it without the transform.

In case of #3, uninstall the other product and work with that vendor to resolve the issue.

In case of #4, the user's IT department will have to deal with any virus issue.

In the meantime the only other suggestion is for customer to try running the System File Checker (SFC) scan on affected the computers and see if it will replace any missing or corrupt files and then check if the issue persists.

To do this:

a) Go to the Windows system folder and right click on cmd.exe and then select the option Run as administrator.

Note: If prompted for an administrator password or for confirmation, type the Admin password, and click     Continue.

b) Type the following command, and then press ENTER: sfc /scannow

 

Environment Details

Products affected: MapInfo Pro™
 

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