VERIFIED SOLUTION i
X

Resolve "java.lang.UnsupportedClassVersionError" when installing Spectrum Patch 10.0 SP1 S07 patch

Issue

The Spectrum 10.0 SP1 S07 patch when deployed on 10.0 shows the below errors in the wrapper.log file.

 | INFO [ReportRuntimeManager] Creating reporting schema for: GeoStan 
 | INFO [Deployer] Deployed: geostan-10.0.car 
 | INFO [Deployer] Deployed: geostan-10.0.console 
 | INFO [Deployer] Deployed: geostan.war 
 | ERROR [ScanDirectoryHandler] Unable to deploy file [ggm-10.1.car] 
 | java.lang.UnsupportedClassVersionError: com/pb/spectrum/globalgeocode/stage/GlobalGeocodeStage : Unsupported major.minor version 52.0 

Cause

The patch is not compatible with 10.0, it is intended for 10.0 SP1.

The error messages shown above demonstrate the patch has been attempted to be installed in 10.0 .

Resolution

UPDATED: October 12, 2017


Please follow the instructions in the the attached release notes and install the patch accordingly.
 

Environment Details


 

Downloads

  • No Downloads