VERIFIED SOLUTION i

EngageOne 3.1.2 JBoss compatibility error

EngageOne_Build_GA-3.1.2.26180.Build35

Issue

The EngageOne installation requirement for JBoss is EAP 6.2.  When update 4 of JBoss is used, the EngageOne installation errors with "JBoss version unsupported".

Cause

EngageOne installation software doesn't allow any JBoss updates beyond EAP 6.2.

Resolution

UPDATED: April 29, 2019
Install JBoss EAP 6.2, install EngageOne, and then update JBoss.  Only the EngageOne installation causes the error.  After the installation, JBoss can be updated.

Future EngageOne releases will allow updates to JBoss before the EngageOne installation.