VERIFIED SOLUTION i

Resolve Error opening Customer View after removing Domain fields Portrait Dialogue

Product Feature: Customer View


 

Issue

In Portrait Dialogue (PD) after doing all of the following:
  • Removing a field from the customer database
  • Removing it from the domain query (and thereby also from the domain)
  • Refreshing the field list in Dialogue Admin
  • Saving the updated changes in Dialogue Admin
  • Refreshing the field list in Visual Dialogue
An error still occurs when trying to open Customer View and Telemarketing, which says something like:

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Error Page
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The following error occurred:
Column '<your_deleted_column_name>' does not belong to table <Your_customer_db_table_name>.

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Cause

This is caused by the the web site caching the domain field definitions.
 

Resolution

UPDATED: April 18, 2017
The solution to this problem is to clear the cache on the MHCustomerView and MHTm web sites.
Restarting the web site is a quick way to clear the cache for everything.

Firstly, make sure that no-one is currently using these web sites.To restart the them, open Microsoft Internet Information Services (IIS) and select the web site.
In the right hand column, there is a Manage Web Site grouping.  In that grouping click on Restart. 
Alternately you can click on Stop, then after a few seconds, click on Start.