VERIFIED SOLUTION i

"Missing Shortcut  Windows is searching for Pitney." or "The system cannot find the file specified" type errors in MailStream Plus on Windows

Product affected: MailStream Plus™
Operating System: Windows

 

Issue

When trying to use MailStream Plus™ (MSP) links, such as to the DB Load program, you may see the error-
Missing Shortcut 
Windows is searching for Pitney.  To locate the file
yourself, click Browse.

Notice it says it is searching for 'Pitney'.
 
Or you may see errors in logs such as-
Try loading ‘e:\apps\Pitney\Bowes\MailStream.acu’...
e:\apps\Pitney\Bowes\MailStream.acu: The system cannot find the file specified.

Notice that there is a ‘\’ between ‘Pitney’ and ‘Bowes’, and that it is looking for a program called ‘MailStream.acu’ (which does not exist.)

Cause

These types of errors are due to the folder/file names not being read correctly.
 
The reason may be that the ability to use 8.3 name formats has been disabled on the installation drive. It needs to be enabled because MSP uses that format to find folders and files.
 
*From a Windows command Line, the command to check if it has been disabled (if you are installing on the e: drive) is-
fsutil 8dot3name query e:

The screen will tell you whether it is enabled or not.

Resolution

UPDATED: May 14, 2019
If it is disabled, the command to enable 8.3 format (for the e: drive) is-
fsutil 8dot3name set e: 0 

This should not affect anything else that is on the drive, it just allows the 8.3 format to be used.  FYI- There is more information about the issue starting here- 
https://support.microsoft.com/en-us/kb/121007 

If MSP has already been installed:
1) MSP should be uninstalled.

2) Delete the already generated “Pitney Bowes” and other sub-folders before re-installation. Because they were created without 8.3 name support (before support for it will be turned on below) they do not have short names.  Deleting them allows them to be created correctly after support is turned on.
 
3) Change the fsutil setting to be enabled.

4) Then reinstall MSP. 

*A full document about this issue is attached.