VERIFIED SOLUTION i

Resolving scale not weighing or not weighing correctly on the DM300C-DM475

Products affected: DM300C™, DM400C™, DM450C™, DM475™

Issue

Your mailpiece does not get weighed correctly by your scale.

Cause

Your scale may not be communicating with your meter, or your scale may not be level.

Resolution

UPDATED: July 1, 2019
Solution 1: Zero your scale
  1. Remove any items from the scale.
  2. Press Weigh/Rate.
  3. Select Zero the Scale.
  4. Test with an item of known weight.
If you have an external weighing platform that sits beside the meter, try Solution 2.

Solution 2: Make sure that your platform is level
  1. Take the top cover off the weighing platform.
  2. Locate the round glass level.
Scale level
  1. The dot should be located inside of the black circle. If the dot is not inside the black circle, adjust the feet on the weighing platform until the dot is inside of the circle.
  2. Test with an item of known weight.
If your scale still does not weigh correctly, try Solution 3.

Solution 3: Remove your scale and restart your meter
  1. Remove the scale from the top of your meter. If you have an external weighing platform, unplug your cable from the back of your meter.
  2. Unplug your power cord.
  3. Wait one to three minutes.
  4. While waiting, put your scale back on top of your meter or plug the external weighing platform back into your meter.
  5. Plug your power cord back in, ensuring that it is plugged directly into a wall outlet.
  6. Test with an item of known weight.
If your scale still does not work, try Solution 4.

Solution 4: Check your serial port setting:
  1. Press Menu.
  2. Select Setup.
  3. Press Page Down.
  4. Select Serial Port.
  5. Select Attached Scale.
  6. Press Home.
  7. Test your meter by placing one letter-sized sheet of paper on the scale. It should weigh 0.2 oz.

Use the Contact Us options below, if you need further assistance. Have your model number ready.