Envelope printing issues in the SendPro Online software for Windows

Learn how to resolve envelope printing issues in the SendPro Online software for Windows.
Products affected: SendPro® Online software for Windows

Issue

Envelopes do not print correctly from the SendPro Online software for Windows. They may be misaligned, have parts missing, or print to the wrong tray.

Cause

The printer settings are not correct.

Resolution

Before you begin

Some of these troubleshooting steps require you to make changes to your printer’s default settings, which may affect other programs. If you wish to avoid changing settings back and forth between SendPro and other programs, we recommend you first install a duplicate instance of your printer by creating custom printer settings dedicated to SendPro.
 

Solution 1: Change your default printer to the printer being used for SendPro

Windows 7

  1. Click Start.
  2. Click Control Panel.
  3. Click Hardware and Sound.
  4. Click Devices and Printers.
  5. Right-click on your printer icon and select Set as default printer.
  6. Restart the SendPro Online software.

Windows 10

  1. Click Start.
  2. Click All apps.
  3. Click Windows System.
  4. Click Control Panel.
  5. Click Hardware and Sound.
  6. Click Devices and Printers.
  7. Right-click on your printer icon and select Set as default printer.
  8. Restart the SendPro Online software.

Solution 2: If nothing prints

Remove the print jobs from the print queue:

Windows 7

  1. Select Windows Start > Devices and Printers.
  2. Right-click on the printer and choose See what's printing.
  3. From the Printer menu, choose Cancel All Documents.

Windows 10

  1. Select Windows Start > Settings.
  2. Select Devices.
  3. Under Related settings, select Devices and printers.
  4. Right-click on the printer and choose See what's printing.
  5. From the Printer menu, choose Cancel All Documents.

Solution 3: If the envelope prints to the wrong printer tray

  1. In the SendPro Online software's printer selection window, choose your printer’s intended envelope tray instead of using the Auto Tray Select option. This tray may be named Bypass, Manual, Manual Feeder, or Envelope feeder.
  2. If the issue is not resolved, set your envelope tray to the default tray for Windows:
    1. Windows 7: Click Start > Devices and Printers.
      Windows 10: In the Windows Search box, type Printer and Devices, then click Printers and Devices in the search results.
    2. Right-click on the printer and select Printing preferences.
    3. Change the default tray to the envelope tray (this may be named Bypass or Multipurpose).
    4. Select OK.
    5. Return to the SendPro Online software and try again.

Solution 4: If the envelope is misaligned, is cut off, prints blank, or your printer software has a paper mismatch error

Ensure that the correct tray and envelope settings are selected in the SendPro Online software:​​
  1. From the SendPro Online software's Print Envelopes screen, select Test Print.
  2. Select the printer in question.
  3. Ensure that the correct tray is selected from the Tray menu for your printer.
  4. Select Set Printer Settings.
  5. Select whether the printer uses Bottom Feed or Top Feed.
  6. Select the printer alignment: Left AlignCenter Align, or Right Align.
  7. Select whether the envelopes are fed Face Up or Face Down.
  8. Select Test Print.

Solution 5: If the issue is not resolved, try changing the envelope size to #9, even if you are using a #10 envelope

  1. From the Print Envelopes screen in the SendPro Online software, select the Change size link at the top next to the envelope size.
SendPro Online change envelope size
  1. Select Envelope #9.
  2. Select Test Print.

Solution 6: If the issue is not resolved, ensure that the correct paper size is selected on your printer

  1. Windows 7: Click Start > Devices and Printers.
    Windows 10: In the Windows Search box, type Printer and Devices, then click Printers and Devices in the search results.
  2. Right-click on the printer and select Printing preferences.
  3. Change the paper size to Envelope #10.
  4. Select OK.
  5. Return to the SendPro Online software and try again.

Solution 7: If the issue is not resolved, set your envelope tray to the default tray

  1. Windows 7: Click Start > Devices and Printers.
    Windows 10: In the Windows Search box, type Printer and Devices, then click Printers and Devices in the search results.
  2. Right-click on the printer and select Printing preferences.
  3. Change the default tray to the envelope tray (this may be named Bypass or Multipurpose).
  4. Select OK.
  5. Return to the SendPro Online software and try again.


Solution 8: If the print is slightly cut off

Try creating a custom paper size. For example, 4.125 x 10" where the length of the envelope is normally 9.5".

​If that is not an option in printer preferences, try the following:
  1. Highlight the printer in the Windows Devices and Printers list. 
  2. Click Print Server Properties.
  3. Check the Create New Form box.
  4. Enter the dimensions and name of the custom paper size. We suggest 4.125 x 10 for a #10 envelope.
  5. Click Save Form. This custom paper size should now be available as a paper size that you can select in Printer Preferences.
Note: If the custom form does not appear in your printer preferences, your printer does not support this feature.

For any envelope issue listed in this article, after all of the above troubleshooting has been performed, you can try changing the duplicate printer you created for SendPro to use a generic or universal printer driver:

Windows 7

  1. Click Start.
  2. Click Control Panel.
  3. Click Hardware and Sound.
  4. Click Devices and Printers.
  5. Right-click your printer icon and select Printer properties.
  6. Click the Advanced tab.
  7. Click on New Driver.
  8. Click Next.
  9. Locate your printer manufacturer from the manufacturer list.
  10. Scroll through the printer driver list and locate a generic driver. The name of this driver will vary per manufacturer. Look for keywords like "Generic", "UPD", or "Universal".
  11. Click Next, then click Finish.

Windows 10

  1. Click Start.
  2. Click All apps.
  3. Click Windows System.
  4. Click Control Panel.
  5. Click Hardware and Sound.
  6. Click Devices and Printers.
  7. Right-click your printer icon and select Printer properties.
  8. Click the Advanced tab.
  9. Click on New Driver.
  10. Click Next.
  11. Locate your printer manufacturer from the manufacturer list.
  12. Scroll through the printer driver list and locate a generic driver. The name of this driver will vary per manufacturer. Look for keywords like "Generic", "UPD", or "Universal".
  13. Click Next, then click Finish.

UPDATED: April 13, 2022