VERIFIED SOLUTION i
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Unable to start Loader and Server services after updating the license key in EngageOne Vault

Issue

Unable to start Vault Loader and Server services after updating the license key. Following are the error observed in the Vault Loader logs:

ERROR: Signature verification for Licence file [<FileName>.xml] failed: License file could not be located or accessed (error = 6)
ERROR: unable to load Licence using settings from [<..>\\server.ini]

Cause

The License file name mentioned in the server.ini either does not exist or that has been opened by another program (For example Antivirus installed on the Server) hence
not getting accessed by Vault Services.

Resolution

UPDATED: June 29, 2017


  • Ensure file name (<FileName>.xml) in the error message observed in the log exist as mentioned in the Server.ini
  • File is not opened currently in any Editor which may hold lock on it.
If Following is the snippet of [License] section in server.ini
[Licence]
LicenceFile=G1keys.xml
LicenceKeyFile=cert.pem
Environment=1

than a valid XML License file with the name 'G1keys' should be present in the same directory where server.ini file is located.

If above conditions are valid but issue persists, restart of machine may help. If issue is still unresolved, contact Client Support.

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