VERIFIED SOLUTION i

Resolve EngageOne version 4 Security Bundle verification failure when authentication LDAP user.

Product Feature: Installation / Upgrade

Operating System: Windows

Configuration: Active Directory
 

Issue

When performing a configuration verification by using the EngageOne 'eos.groovy' installation script, an error is shown stating that verification has failed:
[ERROR] Unable to connect to the ldap://xxx.xxx.xxx.xxx:389 with user EngageAdmin

Cause

When creating a user in Active Directory, the user is created with either a space in the name or the fields 'initials' and 'surname' have been populated. When EngageOne tries to authenticate the user, it connects successfully but is then not able to handle the response with a space in the name (when filling in the initials and surname fields, Windows will add a space between them).

Resolution

UPDATED: July 13, 2017
To resolve this issue, a newer version of EngageOne is required where the issue has been fixed and the installation verification can correctly handle the spaces in a user name. Please contact either Support or your account manager to obtain the latest version of EngageOne.