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Resolve the error message IlleagalAccessError in Spectrum Technology Platform 10.1

Issue

Installed the following database and Spectrum™ Technology Platform updates: 

GeoTax Database Monthly Update - GPM042017_730.zip 
Universal Addressing Module U.S. Database - USS062017_1000.zip 
Platform 10.0 SP1 update S34 - CDQ1010S340101.zip 
Platform 10.0 SP1 update S46 - CDQ1010S460101.zip 
Platform 10.0 SP1 update S48 - CDQ1010S480101.zip 

The system started without error, but now seeing the following error when an address is validated from both a web service accessing the platform and internally in Management Console when using the Validate Address service. 

Group1.ESD.SAL.Services.ServiceServiceException: An error occurred during an operation of service: the service ---> System.Web.Services.Protocols.SoapException: java.lang.RuntimeException: ValidateAddress-ValidateAddress threw IllegalAccessError: tried to access method com.g1.dcg.server.security.SecurityHelper.authenticate(Lorg/springframework/security/core/Authentication;)V from class com.pb.spectrum.platform.server.runtime.core.dataflow.engine.impl.StageRunner 
at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall) 
at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters) 
at Group1.ESD.WebServiceProxies.Service.ServiceManagerService.process(String serviceName, DefinitionProperty[] arg1, PreviewData arg2) 
at Group1.ESD.SAL.Services.ServiceService.Process(String serviceName, DefinitionProperty[] properties, PreviewData data) 
--- End of inner exception stack trace --- 
at Group1.ESD.SAL.Services.ServiceService.Process(String serviceName, DefinitionProperty[] properties, PreviewData data).

Cause

The "IlleagalAccessError" is happening because all the required patches for Spectrum™ Technology Platform 10.1 have not been applied.
 

Resolution

UPDATED: August 31, 2017


Below is a list of the required patches based on the installed modules (ETM & UAM) along with an online link where the patches can be download with their respective release notes. These should be applied in ascending order. 

http://support.pb.com/help/spectrum/ProductUpdateSummary/index.html#ProductUpdateSummary/source/SummaryTable-10.1.html 

The patches and the release notes can also be downloaded from our support site

The needed patches are: 

UAM: 
S08,S17,S25,S29,S48 

EGM: 
S18,S33,S38,S41,S43,S44

Platfrom: 
S06,S09,S16,S26,S30,S34,S46, 

The required sequence is: 
S06 
S07 
S08 
S09 
S16 
S17 
S18 
S25 
S26 
S29 
S30 
S33 
S34 
S38 
S41 
S44 
S46 
S48 

Environment Details

Product affected: Spectrum™ Technology Platform

Operating System: Windows, Linux, UNIX

Versions: 10 SP1

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