VERIFIED SOLUTION i
X

Resolve ERROR 80617 when attempting to view as PDF in EngageOne Vault Service and Admin Client

Issue

When attempting to "view as PDF" in either the Service Client or the Admin Client in EngageOne Vault, the following error is encountered:

User-added image

Cause

This is a defect in the PDF compressor before version 7.2.2.39 resulting in object dependencies being incorrectly handled.

The error message is very specific, but to expand on this, this is the specific information in the PDF that is causing the error:

10 0 obj
<</Type/Font/Subtype/TrueType/Name/F3/BaseFont/ABCDEE+Calibri,BoldItalic/Encoding/WinAnsiEncoding/FontDescriptor 11 0 R/FirstChar 32/LastChar 117/Widths 243 0 R>>
endobj
11 0 obj
<</Type/FontDescriptor/FontName/ABCDEE+Calibri,BoldItalic/Flags 32/ItalicAngle -11/Ascent 750/Descent -250/CapHeight 750/AvgWidth 537/MaxWidth 1956/FontWeight 700/XHeight 250/StemV 53/FontBBox[ -691 -250 1265 750] /FontFile2 244 0 R>>
endobj

This shows that the <<Type/Font object (10 0) is making a reference to the <<Type/FontDescriptor object (11 0), and although this is perfectly valid structure, versions of Vault earlier than 7.2.2.39 are not recording a reference to object 11 0 in the list of dependencies resulting in the error shown.

Resolution

UPDATED: October 12, 2017


Upgrade to a version of Vault later than 7.2.2.39

Environment Details

Product Feature: Render
Versions affected: all 7.x prior to 7.2.2.39
 

Downloads

  • No Downloads