VERIFIED SOLUTION i

Resolve error when specifying Email Server Name in EngageOne Content Author

Product Feature: Configuration Manager

Issue

The error below occurs when clicking on the Apply button in the EngageOne Content Author Configuration Manager after having specified the Email Server name.

User-added image
 

Cause

When the Apply button on the EngageOne Content Author Configuration Manager is clicked, the EngageOne Content Author database is upgraded.
Part of the upgrade process is to recreate the table indexes, which requires certain SQL Server privileges for the SQL Server database.
The user that is running the Configuration Manager does not have these privileges. 
 

Resolution

UPDATED: November 27, 2017
If the Email Server Name is the only setting that needs to be updated, this can be done by editing the web.config file located in the web application directory. 
Locate for the property "SmtpServerName", and change the value accordingly. 

Steps:
1.Go to C:\PBBI CCM\DOC1\Content Author\Client 
2.Edit the file web.xml 
3.Locate <add key="SmtpServerName" value="xxxxxxxxxx" /> 
4.Update the value "xxxxxxxxxx" to specify the Email Server Name. 

The same can be done for the Administration Client by editing the Msg1Admin.exe.config file located in the client install directory. 

​Steps:
1.Go to C:\PBBI CCM\DOC1\Content Author\Admin 
2.Edit the file MSG1Admin.exe 
3.Locate <add key="SmtpServerName" value="xxxxxxxxxx" /> 
4.Update the value "xxxxxxxxxx" to specify the Email Server Name. 

Alternatively, the user running the EngageOne Content Author Configuration Manager must be given sufficient SQL Server privileges to run the database upgrade script.