VERIFIED SOLUTION i

Resolve Failure of Vendor Import Zip File in EngageOne Digital Delivery

Issue

On importing vendor.zip file in EngageOne Digital Delivery, following error is encountered in UI.

Vendor Import Failed error

Error encountered in Log file - 
<Date> <Time>,419 [EM] ERROR [http-apr-8080-exec-1] velocity.logVelocityMessage(143) | Right side ($currentMenu) of '==' operation has null value. If a reference, it may not be in the context. Operation not possible.

Cause

One of the possible root causes:
  • If trying to import vendor.zip file exported from higher version of EngageOne Digital Delivery version.
  • If the exported xml is manually zipped.

Resolution

UPDATED: November 9, 2017
  • Import vendor.zip file exported from same or older version of EngageOne Digital Delivery.
  • Try to import .XML file after decompressing (unzipping) .zip file.