VERIFIED SOLUTION i

Service startup taking longer time in EngageOne Server

Product Feature: Installation/Upgrade
Operating System: Windows/Linux

Issue

EngageOne service takes a long time for the start.

Cause

This could be caused if log level has been changed from the default (WARN) to any higher level (e.g. DEBUG). With higher log level, EngageOne Server will log more information in log files which subsequently impact performance and startup as the logger process consumes memory and time for processing:
  • 'ALL'.
  • 'TRACE'
  • 'DEBUG',
  • 'INFO',
  • 'WARN'
  • 'ERROR'
  • ​​​​​​​​​​​​​​'OFF

Resolution

UPDATED: August 2, 2019
Steps to change the logging level in EngageOne Server (This needs to be followed for each bundle):

1. Open the 'deploy.properties' file existing under 'EngageOne_Server-<version>\install\' directory.
2. Locate key value 'logging.default.level=' and change the logging level to lower level.
3. For best performance set to 'ERROR' and save the file.
4. Reconfigure the bundle.