VERIFIED SOLUTION i

'Transaction (Process ID XXX) was deadlocked on lock resources' message in EngageOne Server



 

Issue

When processing batch with large number of input records, EngageOne Batch (Accumulated or Non-Accumulated) fails with 'Transaction (Process ID XXX) was deadlocked on lock resources' message logged in log.
 
com.microsoft.sqlserver.jdbc.SQLServerException: Transaction (Process ID XXX) was deadlocked on lock resources 
with another process and has been chosen as the deadlock victim. Rerun the transaction.

Cause

This has been identified as a defect prior to release 4.4.6 (4.4SP6). EnagageOne server is not managing the connections to the database and allowing the batch request to try and access the same database object at the same time.

Resolution

UPDATED: May 27, 2019
This has been fixed in EngageOne Server version 4.4.6 (4.4SP6) and later.