VERIFIED SOLUTION i

Access denied error when creating/editing an EngageOne Delivery channel in EngageOne Server

Product Feature: Operational Settings

Operating System: Windows Server


 

Issue

When creating or making changes to an EngageOne® Deliver or e-Messaging delivery channel within EngageOne Server the following error message is displayed:

"e-Messaging returned an access denied message. Contact the e-Messaging administrator".

Cause

Due to an unknown environment change EngageOne Deliver or e-Messaging is no longer authenticating the host name for the EngageOne Server. Without successful authentication, EngageOne Server will not allow creation or changes to delivery channels that have been set to a type of 'e-Messaging'.

Resolution

UPDATED: June 27, 2018
This error can be verified by entering the following path into any web browser from the EngageOne Server machine:

http://<name of EO Delivery server>:8090/emessaging/resource/outboundprofiles

If a list of all the outbound profiles and settings is returned and displayed then authentication is working correctly. If an 'Access Denied.' message is returned then try the following.
  • In the URL previously tried. Replace the name of the server with its IP address.
  • If the server is hosting both EngageOne Server and EngageOne Deliver/e-Messaging try using 'localhost'.
  • If the server is hosting both EngageOne Server and EngageOne Deliver/e-Messaging try using '127.0.0.1'.
Once a working name or IP is found then edit the 'run.bat' file for JBoss (on the EngageOne Server) and look for the JVM setting (-Demessaging.service.endpoint=http://server:8080/emessaging/resource/outboundprofiles) that points to the EngageOne Deliver\e-Messaging server (if on a different machine). Change the address to the working IP/name instead of the current value. Once done, restart JBoss and test the EngageOne Server delivery channels for the error message.