VERIFIED SOLUTION i

Work items not getting picked up during batch execution in EngageOne Server

Issue

During Batch execution work items not getting picked for processing in EngageOne Server.

Cause

During execution, Batch scans table "TDS_REQUESTCHANNELS" and checks whether there are any records waiting to be processed. Batch processes work items on the basis of the following criteria which includes:
  1. BATCHID has to be NULL
  2. IMMEDIACY has to be B (‘batch’)
  3. REQUESTSTATUSID has to be 3 ('Composed')
If any of these are not met, records are not picked for processing.

Resolution

UPDATED: March 28, 2018
Ensure status of Work Items is in 'Composed' state in the EngageOne Interactive.