VERIFIED SOLUTION i

Error "Could not get any response" while using REST API for sending E-mail and SMS from EngageOne Digital Delivery

Issue

Following error is observed in the log on using REST API for sending E-mail and SMS from EngageOne Digital Delivery:
"Could not get any response
There was an error connecting to http://<IP>:<PORT>/EODigitalDelivery/ resource/v1/messages/email"

The URL is not accessible from API client (for example Postman).

Cause

It could be caused due to invalid content in header or content in incorrect case as header is case sensitive for example 'Content-Type' mentioned as 'Content-type'.

Resolution

UPDATED: April 13, 2018
Check the content and case of header. If the issue still exists, contact Software Support.