VERIFIED SOLUTION i

Resolve queries regard the logic affecting changes to Enquiry Alert Types in Confirm

Products affected: Confirm®
Product feature: Customer Services / Enquiries
 

Issue

In Confirm® you have an Alert Type (similar to that shown below) that is just for one Service Type – in this example 'Highways Maintenance'. If you were to make that Service selection blank, will it only start sending Alerts for other Service Types from now on, not sending Alerts for retrospective Enquiries that are currently at the 'Job Raised' Status?

Enquiry Alert Type - Service selection

Cause

These question arose as a result of you wishing to modify at least one Alert Type.

Resolution

UPDATED: May 8, 2018
If you blank the Service selection for an existing Alert Type, it will start sending Alerts to all Service Types. 

It won’t do any retrospective Enquiries. For Enquiries at an applicable Status for alerting, but that have already been processed by the Agent, no Alert will be sent just by changing the Alert Type. This is because these Enquiries did not qualify at the time the Agent ran.

If, however, a change is made to an Enquiry, then it will be considered for an Alert (as the Alert Type rule now applies) and one may be triggered depending on the Alert Type (e.g. a 'Follow Up' Alert could be triggered, but an 'On Creation' one would not).