VERIFIED SOLUTION i

Error 421 4.4.1 in EngageOne Deliver when sending emails

Product Feature: User Interfaces
Versions affected: Prior to 2.2.2

 

Issue

When sending emails through EngageOne® Deliver, the following error is encountered:

Error occurred in e-documents profile: 421 4.4.1 Connection timed out 

Error occurred in e-documents profile: Message not sent successfully

Cause

When EngageOne Deliver sends a message to a mail server, it may take some time to respond, causing the timeout.

This error is likely to occur if the time out settings in EngageOne
 Deliver and the email server are not set at a sufficiently high value.

Resolution

UPDATED: July 5, 2018
To reset the timeout value for the email server, modify the value in the following parameter in the outboundProcessor.properties file (found in <installation path>\WEB-INF\classes folder):
 
# SMTP properties settings(timeout, connectiontimeout, writetimeout all values in milli seconds), comma separated properties
mail.smtp.properties=mail.smtp.timeout=120000;mail.smtp.connectiontimeout=120000;mail.smtp.writetimeout=120000

A change has been made to EngageOne Deliver (patch for V2.2.2), so the retries will be increased, but this too requires a change to a setting in the outboundProcessor.properties file as follows:

# This property is applicable only when outbound.reuseEmailConnectionForBatch=true
outbound.email.messageCountPerConnection=nn (user defined)
 
The purpose of of this parameter is to determine how many messages can be sent in a single connection.  Once this value has been reached, the application should close the connection and open a new one.  Opening a new connection takes time, so the purpose is to reduce the number of times this happens for performance purposes.