VERIFIED SOLUTION i

'Authentication Failed' in EngageOne Server 4.X after changing password of AD/LDAP account

EngageOne Server 4.X

Issue

On changing password for AD/LDAP Account used to access the EngageOne, login attempt fails with 'Authentication Failed'.

User-added image

Cause

After changing the password of a AD/LDAP account, there is a need to update same in the EngageOne so that It can be used to authenticate user over AD/LDAP. This problem could be caused if AD/LDAP password has been changed (expired) but not yet reflected in EngageOne.

Resolution

UPDATED: July 5, 2018
Every AD/LDAP password change requires updation in EngageOne. To reflect changed password in EngageOne, there is a need to run the installation script with 'configure' option for all EngageOne services after specifying the new password (encoded) in the deploy.properties. For more information, refer section 'Configuration changes' in 'EngageOne Server Installation guide' provided as a part of product documentation.