VERIFIED SOLUTION i

Error 'Access is denied' is observed while saving a Message Template in Visual Dialogue

Product Feature: Visual Dialog

Issue

Error 'Access is denied' is observed while saving a Message Template in Visual Dialogue.

Following error is recorded in the Dialog Server Error logs:
Exception: Cannot create file "\\<Server_name_IP>\MH\Instances\pd\CustDomains\<Database_Instance>
\Dialogs\<Dialog_name>\Messages\9115.txt". Access is denied

Time: 7/27/2018 4:02:29 PM
Module: C:\Program Files (x86)\PST\Million Handshakes\Dialog Server\MHOutputMessagePlugins.dll
Version: 6.2.0.1216
File date: 4/13/2018 10:43:00 AM
Instance name: pd
Username: internal
ProcessID: 3016
ThreadID: 4360
Memory usage: 69.63 MiB
Exception type: EFCreateError
Procedure: System.Classes.TFileStream.Create

Cause

The error is observed due to the insufficient permission assigned to the user logged in to Visual Dialogue.

Resolution

UPDATED: July 30, 2018
Assigning sufficient permission to the user logged in to Visual Dialogue to access the folder where the "Message Templates" are created can resolve this error. If the "Message Templates" are created at a remote location, then the user must have 'Read/Write' permission on the folder.

PS: The location of the folder is recorded in the Dialog Server error logs.