VERIFIED SOLUTION i

Portrait Dialogue: 'Error 27504. SQL version requirements not met' during Database Installation

Issue

While installing Portrait Dialogue database on SQL Server 2012 the process encounters error:
Error 27504. SQL version requirements not met: (server). This installation requires Microsoft SQL Server 'version' or later

Cause

Portrait installer executes @@version scalar function on the SQL Server chosen to host Portrait database. This error could be caused due to the fact that SQL Server returns response of @@version in unexpected format. For example, while installing portrait 6.1 dialogue database on SQL Server 2012 SP2, response of @@version return some additional information unexpected by Portrait installer (highlighted in bold).

Microsoft SQL Server 2012 (SP2-CU7) (KB3072100) - 11.0.5623.0 (Intel X86)



 

Resolution

UPDATED: March 30, 2017
Ensure supported database server is used to install the Portrait Dialogue. For more information on supported database servers, refer
release notes of corresponding version shipped with the installer package. In this case, Microsoft SQL Server 2012 SP2 was not certified with
Portrait 6.1. Switching to certified database servers resolved the problem.