VERIFIED SOLUTION i
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Sagent Weblink: Unable to connect to the Sagent repository.

Issue

Weblink throws an error when using 'Short login' form in the 64-bit Sagent environment.

Exception: Unable to connect to the Sagent repository. SA -- 0x1, SAIDC -- 0x2A {SaItServer.exe - 00000019 - 2016/06/06 10:42:13.823} [CANTOPEN] Unable to open : access library. Unknown server type or type not supported on this platform: SA -- 0x1, RW -- 0x142 {SaItServer.exe - 00000017 - 2016/06/06 10:42:13.823} Information from server: 0 SA -- 0x1, RW -- 0x1B {SaItServer.exe - 00000018 - 2016/06/06 10:42:13.823}

Cause

In case of Short login form, repository info is picked from the repository information saved in the registry.
Sagent Admin saves repository information. Sagent Admin is 32-bit application and it saves the information to the WOW node [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sagent\DataMart\RP\Profiles\].

64-bit Weblink does not find this information because it doesn't look into WOW node instead it searches the main node [HKEY_LOCAL_MACHINE\SOFTWARE\Sagent\DataMart\RP].

This is a known bug that has not been scheduled for a fix.

Resolution

UPDATED: April 10, 2017


The following workaround can be used to resolve this issue:
  • Take a backup of Sagent folder in the registry located in
    [HKEY_LOCAL_MACHINE\SOFTWARE\Sagent\].
  •  take backup of Sagent folder in [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sagent].
  • export [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Sagent\DataMart\RP\Profiles\].
  • import it in the main node [HKEY_LOCAL_MACHINE\SOFTWARE\Sagent\DataMart\RP]. 
If the issue is still not resolved, contact client support. 

Environment Details

Product Feature: Weblink Server

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