VERIFIED SOLUTION i

Error that setuprts was not found in MailStream Plus on UNIX/Linux

Product affected: MailStream Plus™, all versions
Operating System: UNIX/Linux

Issue

Setuprts is called from within the setup script.
While sourcing the 'setup' script that is always sourced prior to using MailStream Plus™ (MSP), a setuprts not found error is encountered. 

Cause

This may be due to the PBDIR variable in the setup script incorrectly pointing to '/opt/pb' or other wrong location instead of the location where the MSP software was actually installed.  

For example, say during running the install script MSP is installed into /users/local.  Then under that will be the msn folder, and under msn will be the bin, data, lib, and rts folders.

The setuprts script is located in the msn/bin folder, and part of the path to it in the setup script is determined by the PBDIR variable.
 
In the example given above, where the MSP install was set to /users/local, that is what should be the PBDIR value-
PBDIR="/users/local"; export PBDIR   # Full path to Pitney Bowes tree

In some cases the PBDIR value in setup may not be correct, and may incorrectly be "/opt/pb" (or other value).  

In one case this happened because a user had simply copied the setup.new script to be 'setup'.  setup.new had the default 'placeholder' value used for PBDIR of /opt/pb.

Note- /opt/pb is normally *not* where PBDIR should be set to, unless the MSP software was actually installed there.  And we recommend that Pitney Bowes Software applications *not* be installed in /opt/pb, because that is typically on the root drive and may cause space issues during production runs.

Resolution

UPDATED: March 14, 2019
Set the PBDIR variable to the correct location where MSP is installed.