VERIFIED SOLUTION i

Resolving error: "FailedToRetrieveTemplateInformationException" in EngageOne 3.X


 

Issue

Batch execution fails due to template not getting located in a domain though template exist at the path specified in Input/trigger file.

Message in Batch log:
com.pb.engageone.server.batch.exception.FailedToRetrieveTemplateInformationException: The
<Template Path> template in the <domain> domain could not be retrieved. See the system logs for details.

Message in Application Server log:
com.g1.ocm.api.TemplateException: The <Template Path> template is not found in the <domain> domain. In EngageOne Administration, select the template in the Templates tab to make sure the template name and path are correct.

 

Cause

Could be caused by a defect in EngageOne before Version GA-3.1.2.25573.Build12.

Resolution

UPDATED: November 8, 2018
Upgrade to 'GA-3.1.2.25573.Build12' or version/build released after that. If EngageOne version prior to that is being used, following delete statement can be executed on EngageOne database as a workaround:

DELETE FROM DOC_RESOURCES WHERE FR_TYPE = 'D' AND STATUS = 'A'

Note: It is recommended to take complete (both Active-drive and database) backup of EngageOne before running this query.