VERIFIED SOLUTION i
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Resolve issue where Scheduled Tasks are stuck at 1% with "Exception caused when calling AgentProcess.Run. Marking process xxxxxx as broken, and should be stopped." error in Confirm Task Processor

Issue

Scheduled Tasks are stuck at 1% with "Exception caused when calling AgentProcess.Run. Marking process 115180 as broken, and should be stopped." error in the Task Processor logs.

This will probably be only affecting the powerbuilder based agents (Alerts and Notifications, Scheduled Reporting Agent).

Cause

This is normally caused by a corruption of the Task Processor config file.

Check the config file as per the installation docs for any errors.

You can use the Confirm client config file as a guide as they should be more or less identical regarding the connections to the database.

Resolution

UPDATED: September 21, 2017


Recreate the Task Processor config file as per the installation documentation. 

Once done, restart the Confirm Task Processor service.

Environment Details

Product Feature: Application Infrastructure


 

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