VERIFIED SOLUTION i

Slow navigation in EngageOne Administration


 

Issue

Slow Navigation in EngageOne Administration. Switching to different tabs may take few seconds.

Cause

Possible scenarios could be:
  • Insufficient free memory (RAM).
  • Insufficient Java Virtual Memory (JVM) heap size.

Resolution

UPDATED: April 21, 2017
  • Increase RAM of machine where EngageOne Application Server is hosted. Free RAM on the machine can be checked either of following
  • PerfMon counter 'Memory\Available Mbyte'.
  • 'Available Physical Memory' returned from systeminfo DOS command
  •  From Performance tab of Windows Task Manager. Refer attached screenshot showing 1827 free RAM on the machine.
     
  • Check the JVM statistics using any of the tools bundled with JDK for example Jconsole. Refer using Jconsole for more information.
Increase Minimum (-Xms) & Maximum (-Xmx) heap size, if required. JVM settings are available in:
  • Jboss 5.1 is in  run.conf.bat located in <JBOSS_HOME\bin> directory
  • Jboss 6.2 is in standalone.conf.bat located in <JBOSS_HOME\bin> directory​
 
  • If performance of EngageOne Administration is slow on remote machine (other than one on which EngageOne Application Server is hosted) only, this could be due to low network bandwidth between Client and Server machine.