VERIFIED SOLUTION i

'The session has expired' message observed while opening a dialogue in Portrait Dialogue

Product Feature: Visual Dialogue

Issue

Error 'The session has expired' is observed while opening a dialogue in Visual Dialogue.

Visual Dialogue Session Expired.JPG

Cause

This could be caused due to corruption of information associated with 'signed in' user.

Resolution

UPDATED: October 16, 2018
As a workaround, following steps could help:
 
1. Open Dialogue Admin and navigate to 'Database Instance' > 'User and security' > 'Object Security'. Change the ownership of all the objects (Dialog/Template/Selection) created by User.

Dialogue Admin Object Security.JPG

2. Navigate to 'Database Instance' > 'User and security' > 'Users'. Delete the 'User' and re-create it.
3. Login to Portrait HQ to verify that the user is able to access 'Portrait Shared Server'.