VERIFIED SOLUTION i

Login attempt to client fails with 'com.pb.common.exception.ServiceExceptionMapper' message in core logs of EngageOne Server 4.X

Issue

On logging in EngageOne Server, below error encountered under core log file:

<Timestamp> | DEBUG | com.pb.viewpoint.common.service.principal.PrincipalServiceBasedOnOpenAmData] Search OpenAM for principal with name:
[<Timestamp>| ERROR | com.pb.common.exception.ServiceExceptionMapper] Response ViewpointException received: null
com.pb.viewpoint.common.exception.InvalidInputException: null
at com.pb.viewpoint.common.service.principal.PrincipalValidator.throwInvalidInputException(PrincipalValidator.java:60) ~[common-core-4.4.7.Release.jar:na]
at com.pb.viewpoint.common.service.principal.PrincipalValidator.validateNames(PrincipalValidator.java:67) ~[common-core-4.4.7.Release.jar:na]

Cause

This could be caused due to 'solr.slaves.ip.addresses' not set in the viewpoint.properties under <..>/core/conf directory.

Resolution

UPDATED: September 19, 2018
Set 'solr.slaves.ip.addresses' field with the server I.P address in the viewpoint.properties under <..>/core/conf directory and restart the EngageOne Core Service.