VERIFIED SOLUTION i

Bundle logs not rolling over in EngageOne Server

Issue

EngageOne bundle logs are not rolling over as expected. Due to this, log file that gets created keeps increasing in size.

Cause

It could be caused due to log file being locked by a thread.

Resolution

UPDATED: September 21, 2018
As a workaround, logger can be forced to roll over log files by adding property </prudent> as 'true' to <EO_Installation_Path>\<bundle>\conf\logging\logback-global.xml.

User-added image

</prudent> is added and set to 'true', by default in EngageOne 4.4 SP5 and later releases. 'logback-global.xml' exists in each bundle so depending on the requirement, changes need to be made in this file corresponding to each bundle.

Note: It is required to restart EngageOne Service(s), corresponding to the bundle(s) in which changes are made.