VERIFIED SOLUTION i
X

How to import an ESRI shapefile (.shp) into MapInfo Pro

UPDATED: September 21, 2017


There are two different methods to import an ESRI .shp file into MapInfo Professional® and Encom Discover™.

A: Use MapInfo's File>Open menu option, and set the Files of Type to ESRI Shapefile. This option
requires the user to specify a projection, and the file is read-only (it cannot be edited within MapInfo).

B: Use the Universal Translator. This option will pick up the projection information in the shapefile, and
creates a MapInfo table that is editable.

    To use the Universal Translator:

    1/. Within MapInfo navigate to Tools>Universal Translator, open up this tool by clicking on the menu
         item.

    2/. In the Universal Translator dialog, set the Source Format to ESRI Shape.

    3/. Browse to and select the Source Files (Note that one can batch convert by selecting multiple files).

    4/. Set the Destination Format as MapInfo TAB

    5/. Specify the Destination Directory location by browsing.

    6/. Press OK and open the generated MapInfo tab file using the MapInfo File>Open command.

 

Environment Details

Products affected: MapInfo Pro™,  Discover™

Downloads

  • No Downloads