VERIFIED SOLUTION i
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Resolve 'OpenOfficeException: could not obtain service: com.sun.star.frame.Desktop' observed in EngageOne Digital Delivery

Issue

Report generation fails with exception following exception:

YYYY-MM-DD hh:mm:ss,ttt [EM] WARN [http-8080-2] OpenOfficeConnectionWrapper.getDesktop(111) | could not obtain service: com.sun.star.frame.Desktop
com.artofsolving.jodconverter.openoffice.connection.OpenOfficeException: could not obtain service: com.sun.star.frame.Desktop
Caused by: java.net.ConnectException: connection failed: socket,host=<server IP>,port=8100,tcpNoDelay=1: java.net.ConnectException: Connection refused: connect
                at com.artofsolving.jodconverter.openoffice.connection.AbstractOpenOfficeConnection.connect(AbstractOpenOfficeConnection.java:75)
                at com.artofsolving.jodconverter.openoffice.connection.AbstractOpenOfficeConnection.getService(AbstractOpenOfficeConnection.java:111)
 

Cause

Possible root causes could be:
  • OpenOffice service not listening on the <hostname>:<port> specified in the file <EngageOne_Digital_Delivery _Home>\core.war\WEB-INF\classes\openoffice.properties.
  • <Port> not being opened for inbound connection, If EngageOne Digital Delivery is installed on a different machine than OpenOffice.
  • Non-english version of OpenOffice used.

Resolution

UPDATED: August 22, 2017


  • Ensure OpenOffice service is available on the <hostname>:<port> specified in the 'openoffice.properties'.
  • If EngageOne Digital Delivery is installed on a different machine than OpenOffice, <port> should be blocked for inbound connection.
  • If above suggestions do not work, using the English OpenOffice may help.

Environment Details


 

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