VERIFIED SOLUTION i
X

Resolve GraphMap has encountered an unexpected error in MapInfo Discover

Issue

When opening a TAB file with the GraphMap module, an Application Warning (System.Argument.Exception) displays, Details: Unable to find the requested .NET framework Data Provider. It may not be installed.

Application Warning - System.ArgumentException

Cause

Possible corruption of the Microsoft SQL Server Compact 3.5 SP2 ENU prerequisite.

Resolution

UPDATED: April 21, 2017


  1. Navigate to Control Panel > Programs and Features and search for Microsoft SQL Server Compact 3.5 SP2 ENU.
  2. Right-click on Microsoft SQL Server Compact 3.5 SP2 ENU and select Repair. You can also repair by downloading the installer from Microsoft.
Important Note: On a 64-bit computer, install both the 32-bit and 64-bit version of the SQL Server Compact 3.5 SP2 MSI files. Existing SQL Server Compact 3.5 applications may fail if only the 32-bit version of the MSI file is installed on the 64-bit computer.

If the issue is still not resolved, contact client support.



 

Environment Details

Product affected: MapInfo Discover

Downloads

  • No Downloads