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How to resolve "Jet Engine" errors at startup or errors when opening .xls/.xlsx/.mdb, etc. files in MapInfo Pro 32-bit

Issue

Installed products: Office 64-bit and MapInfo Pro 32-bit.

When MapInfo Pro is started, the following error appears:
"the Microsoft Jet Engine is not available for error information"

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If a user attempts to open an.xls/.xlsx/.mdb, etc. file, the following error is displayed:
"Unable to create MapInfo table from file. Please check that the file is valid and available for write access"

User-added image


 

Cause

Mapinfo Pro requires 32-bit Office Drivers, and due to the presence of Office 64-bit drivers, the required 32-bit drivers are sometimes not installed automatically. This is due to a Microsoft Policy.

Resolution

UPDATED: March 23, 2017


MapInfo Professional (32-bit) requires 32-bit Access drivers but if Office 64-bit is installed, the 32-bit Access driver are sometimes not installed.
To resolve, download and  install the Office 2007 32-bit driver by right-clicking and choosing "Run as Administrator" in Windows Explorer
See the MapInfo Pro Release Notes for more information on this issue.

Environment Details


 

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