VERIFIED SOLUTION i
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Resolve Single Record "XXXX" occurs more than once when saving Data format in EngageOne Designer

Issue

When trying to save a data format in EngageOne Designer, an Integrity error gives a warning 'Single record "XXXXX" occurs more than once':

User-added image

 

Cause

This occurs when the same record appears more than once within a single data frame and the record has not been marked as a single repeating record.
Following this warning, Data Format can be saved but it will not work in production until the error is corrected.

Resolution

UPDATED: March 7, 2018


The records mentioned in the error need to be marked as "repeating records".

To do this, select the corresponding record in the tree, right click, and choose "Single Repeating":


Note that all single repeating records must be grouped together, it is not possible to place records between the repeating record id, for example:

RECORD1
RECORD1
RECORD1
RECORD2
RECORD1
RECORD1
RECORD1
RECORD2

In this situation RECORD1 and RECORD2 should for a repeating group.

Note that it is not possible to have the same record key as part of two different groups when using keyed data.  For example:

RECORD1
RECORD2
RECORD3
RECORD2

In this scenrio, RECORD1 and RECORD2 are a group, but RECORD3 cannot have RECORD2 in a group unless this is XML data structure as follows:

<Record1>
<Record2></Record2>
</Record1>
<Record3>
<Record2></Record2>
</Record3>

In this situation, RECORD1 and RECORD3 are two distinct tag groups, so and child tags in these groups are unique to that parent tag group.

Environment Details

Product Feature: Data Format Editor
 

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