UNVERIFIED SOLUTION i
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Resolve issue where MapInfo Professional is Crashing When Zooming and Panning

Issue

MapInfo Professional is crashing.

Cause

MapInfo Professional is crashing after using the zoom and/or pan tool multiple times.

Resolution

UPDATED: August 25, 2017


There are various reasons why MapInfo Professional might crash when panning or zooming. Please try the following to resolve the crashing issue:
  1. Right click on the MapInfo Professional icon, then select "Run as Administrator".(for Windows 7/8)
  2. Update your Video Card Driver to the latest version. In some cases, a problem is introduced with the latest Video card driver so you may need to try rolling back to the previous driver.
  3. Try lowering your Video Card's Hardware Accelleration - sometimes when set to the maximum, problems such as this occur in MI Pro. For Windows 7/8: http://help.aol.com/help/microsites/microsite.do?cmd=displayKC&docType=kc&externalId=15392    For Windows XP: http://pcsupport.about.com/od/fixtheproblem/ht/hardwareacc.htm
  4. Are your files local or on a network drive? In some instances the connection to the server can timeout or have other issues. Please move your files to the local machine.
  5. Additionally, large files, such as rasters, can cause MapInfo Professional to crash. Try removing the raster files, or just opening a small file to see if MapInfo Professional is still crashing.
  6. It is possible that your Windows profile is corrupt, a program is effecting MapInfo Professional or the permissions are causing the crash. If an Administrator or another user logs on your computer, this may resolve the issue.
  7. Review the errors in the Event Viewer found in Admin Tools when MapInfo Professional crashes -  These could help identify what other application is causing the crash.
These steps will help narrow down the issue. In the event that none of the suggestions solve the issue, please contact Technical Support.
 

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