VERIFIED SOLUTION i
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Resolve "Check out failed for UNC/CAA/RealTime" in Spectrum

Issue

When performing a SOAP, REST, or Client API request, you get a response that includes an error which reads:

java.lang.RuntimeException: ValidateAddress-ValidateAddress threw LicenseException: Feature CAA does not exist in license. Check out failed for UNC/CAA/RealTime.

You may also see a similar error message ending in "Batch" during a batch job.

Cause

CAA is the Canadian portion of the Universal Address Module (UAM) Validate Address service. The error message indicates that an address is being requested to be validated but the current licensing does not allow the Canadian Addressing feature. Even if you are using an address that is explicitly not a Canadian address, this message will be given if Canadian Address Processing has not been disabled.

 

Resolution

UPDATED: March 8, 2018


Note: If you believe you should be licensed for UAM Canadian Realtime processing, contact your account manager or Client Services to check on the status of your license, and have a new license issued if necessary.

For Spectrum 10 SP1 and older versions:
  1. Open your Management Console desktop application. 
  2. Login with your credentials.
  3. Click through to the Universal Addressing > Services > Validate Address > Canadian Address Options.
  4. Disable the Enable Canadian address processing option.​
For Spectrum 11 SP1 and newer versions:
  1. Open your web browser
  2. Enter the URL http://<servername>:<port>/managementconsole/
  3. Login with your credentials.
  4. Click through Services > Universal Address > Validate Address
  5. Uncheck the Enable Canadian address processing option.
If the issue is still not resolved, contact client support.

Here is a video demonstrating these steps for Spectrum 11.0 and newer:

Environment Details

Product affected: Spectrum™ Technology Platform
 

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