VERIFIED SOLUTION i
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Resolve Error: LicenseException: "Mode Batch does not exist in license. Check out failed for UNC/CAA/Batch" in Spectrum

Issue

User is getting the following error when running a batch job process:

INFO   | jvm 1 |  ERROR [JobProcessImpl] Exception thrown by Stage:VA1 in dataflow xxx_Job: com.g1.dcg.stage.LicenseException: Mode Batch does not exist in license. Check out failed for UNC/CAA/Batch.

 

Cause

Possible causes:
  • Not licensed to batch geocode in Universal Addressing Module Canadian component
  • Canadian address processing option is enabled when it is not required

Resolution

UPDATED: April 23, 2017


A new license needs to be created for the feature to be activated. Please open a case with the Support Group by sending an email to "Software.Support@pb.com" or calling "1.800.367.6950 option 1 and option 2" and they will have Fulfillment investigate your license. 
Remember to export your current license from Management Console and attach to the email you are sending the Support Group. 


In some cases, revise the dataflow or code where the call is made to Spectrum and verify the Canadian options enabled as further described in the following lines:
 
PerformCanadianProcessing = N
PerformInternationalProcessing = N

Environment Details

Product Feature: Installation / Upgrade

Operating System: Linux

Version: 7,8,9
 

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