VERIFIED SOLUTION i
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Vault: What to do when you observe Operational Delays

Issue

I see operational delays in Vault.  Should I be concerned about this?

Cause

A Vault log shows an operational delay, i.e.,
 
00:42:24 ERROR 15115: begin read operation delay, code [1450]
00:42:24 ERROR 15116: end read operation delay, code [0]
         0    10   20   30   40   50   60   70   80   90   100
         |    |    |    |    |    |    |    |    |    |    |
         XXXXXX

Resolution

UPDATED: November 6, 2015


The codes in the error message are informative.  in this case:
 
00:42:24 ERROR 15115: begin read operation delay, code [1450]
00:42:24 ERROR 15116: end read operation delay, code [0]
         0    10   20   30   40   50   60   70   80   90   100
         |    |    |    |    |    |    |    |    |    |    |
         XXXXXX

code [1450] is a Windows error message.  You can see what this means by typing:

net helpmsg 1450 

at the command prompt:

C:\> net helpmsg 1450
Insufficient system resources exist to complete the requested service.

This could mean that the Vault server was experiencing heavy traffic, or is running low on available RAM.  This message should be taken seriously and an investigation should be undertaken to determine the underlying cause.

Likewise code [0] is a Windows error message:

net helpmsg 0

C:\> net helpmsg 0
The operation completed successfully.

This means that despite the 1450 error experienced earlier, eventually the task did complete successfully.

If you saw a different return code such as:

00:22:31 ERROR 15116: end read operation delay, code [1450]

This would mean that the task did NOT complete successfully, and could cause much more serious problems.
 

Environment Details

Vault on Windows, 5.3, 5.4, 5.5, 6.0, 6.1, 7.1

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