VERIFIED SOLUTION i
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Resolve error "An item with the same key has already been added" in the Message Receiver log for Mail360 DataManager

Issue

In the Message Receiver log the User is getting "An item with the same key has already been added" error which caused failed file processing.

Due to this, customer observed that lot of scans started going into unmatched.

The same error message can be seen in the input_files of the Data Manager database in the error_message column which corresponds to the failed job file.

As input file ingestion  failed, customer was not able to track the Mail Pieces which were in that file.

Cause

Customer was having two outbound records (high-lighted in Red in the attached screenshot) for a Mailpiece Set record which should not be there as one mail piece(which have a unique IMB) cannot be sent out to two customers.

Resolution

UPDATED: October 30, 2017


1) User was asked to delete one outbound record and keep the one on which mail piece will be actually delivered.
2) Either put in the job file in  the hot folder (here this will be treated as a new Mail Piece file) OR use the tech note to correct the failed job file.

Environment Details

Product Feature: General

Operating System: Windows 2008

Database: SQL Server 2008

 

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