VERIFIED SOLUTION i

Resolve MapInfo Pro License Server Utility error: "License Broken"

Product Feature: Licensing

Operating System: Windows7-64bit


 

Issue

User experiences any of these problems:

-  License Server doesn't show the correct count of "Borrowable" licenses.
 - The license server log shows that all the licenses are "broken".
 - Users unable to activate/transfer the license.

Cause

The MapInfo License Server Utility gets corrupted when the anchor service stops communicating with the Flexera server.
All the available/existing licenses in the license server display a "Broken Restore" error, after which no user is able to activate or transfer the license.
This can happen when a user upgrades their Operating System where the License Server Utility is installed.

Resolution

UPDATED: August 20, 2019
There is no solution if license gets "Broken Restore" stage. Moreover, I am mentioning couple of steps to avoid the kind of error or we can try to restore the license.

1) Take a back of two files (unisw20_004e4200_tsf ; unisw20_004e4200_event) you can find these files under the C:\ProgramData\FLEXnet.

2) Stop the MapInfo License Server and FLEXnet Licensing Service from services.

3) Deploy serveractutil.exe on customer environment for temporary purpose.

4) Open CMD and run the command form the Dir where you have saved the said utility serveractutil -repair <fulfillmentID> -comm soap -commServer http://license.mapinfo.com:8080/flexnet/services/ActivationService?wsdl it will repair all the Broken Restore licenses from Flexera (if possible).