VERIFIED SOLUTION i

Backup or snapshot process does not create zip file in EngageOne Designer

Product Feature: Utilities

 

Issue

When creating a repository backup or a snapshot, no zip file is created.

Error: 
M58: Error running full backup.
[Microsoft][ODBC SQL Server Driver][SQL Server]Error creating Zip file, Backup has failed

Cause

XCEEDZIP is unregistered

Resolution

UPDATED: July 9, 2019
registering XCEEDZIP again:

1. Search your hard drive for XceedZip.dll. The program should be found in the Binn folder of your SQL server installation. It should also be found in the EngageOne_Designer_install_path\Designer\... folder.
2. Open a windows command prompt (Start > Run > cmd.exe)..
3. Navigate to the folder where XceedZip.dll is found, using the cd command.
4. Enter the command "regsvr32 (or 64) /u xceedzip.dll" (without the quotes). This will unregister the dll.
5. Enter the command "regsvr32 (or 64) xceedzip.dll" (without the quotes). This will re-register the dll.
6. Exit the command prompt.
7. Open the Repository Configuration Tool and try to do a repository backup. If successful, open the Designer and try to import/export a publication snapshot.

If this has no effect then it's likely that the user under which the SQL service is running does not have the appropriate permissions to the filestore folder, and this should be investigated, if this also does not resolve the problem, please contact technical support (software.support@pb.com)