VERIFIED SOLUTION i

Resolve "The application was unable to start correctly (0xc0000005)" in MapInfo Discover 3D or Discover PA

Products affected: MapInfo Discover 3D™, Discover PA™
 

Issue

When launching MapInfo Discover 3D or Discover PA, the application attempts to launch and then terminates with error:

The application was unable to start correctly (0xc0000005). Click OK to close the application.
 

Cause

The Earth Resource Mapping Base Map DLL library version is corrupted. It is still unclear why this DLL causes an access violation (0xc0000005) on some computers and not others and may be an corrupted installation issue.
 

Resolution

UPDATED: June 24, 2019

1. Click Start > Run. Type in: regedit and click OK.

2. In the Registry Editor navigate to: 
  • MapInfo Discover: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Earth Resource Mapping\Discover3d(libversion6.0).
  • Discover PA: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Earth Resource Mapping\ PA(libversion6.0)
3. Right-click and Rename the value BASE_PATH to BASE_PATHX
User-added image

 
If the issue is still not resolved, contact client support.

Interested to know more, please read these related articles on MapInfo Discover.
https://li360.pitneybowes.com/s/article/Resolve-performance-issues-in-MapInfo-Discover-3D-and-Discover-PA
https://li360.pitneybowes.com/s/article/How-to-obtain-evaluation-licence-for-MapInfo-Discover-Discover-PA-and-more
https://li360.pitneybowes.com/s/article/How-to-transfer-license-for-MapInfo-Discover-Discover-PA-and-more-from-one-computer-to-another
https://li360.pitneybowes.com/s/article/How-to-park-licence-for-MapInfo-Discover-Discover-PA-and-more

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Note: the Discover applications are now officially supported by Datamine:

For Canada and US customers:
Australia:
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