VERIFIED SOLUTION i

Resolve Automate: System.Data.SqlClient.SqlException (0x80131904): Cannot insert the value NULL into column RowID

Product Feature: Repository

Product Version: Automate BPA 9.0.0.25

Issue

Network Automate Error: System.Data.SqlClient.SqlException (0x80131904): Cannot insert the value NULL into column 'RowID'

Cause

Source: Automate BPA Server:

A TableAdapter 'Update' operation encountered an error.

System.Data.SqlClient.SqlException (0x80131904): Cannot insert the value NULL into column 'RowID', table 'AutomateBPA.dbo.executionevents'; column does not allow nulls. INSERT fails.
The statement has been terminated.

This is a known defect.

Resolution

UPDATED: August 31, 2017
This is a known defect in v9.0.0.25 which is in release version of BPA Server 9. 

Upgrade to latest version of Automate BPA to resolve the error. Refer Automate BPA website to check for latest releases.

Backup the database before upgrading (this is not required but recommended). If the installation was done with SQL Express, go into the SQL Server folder in Program Files/Program Files (x86) and make a copy of the database files.
 
Upgrade Process:
1. Uninstall BPA from Add/Remove Programs - When Prompted to check "remove all" options, do not check any options, just uninstall
2. Make sure the AutoMate BPA Server 9 folder under program files C:\Program Files or C:\Program Files (x86) has been removed
3. Install the latest available version
4. During install choose Advanced Setup and select "Use existing configuration,"
 
Note: All components will need to be updated (i.e. remote Agents).