VERIFIED SOLUTION i

MapInfo Licence Validation Error -158

N/A

Issue

When starting MapInfo Professional an error -158 appears.  Running the TS_View tool on the machine also returns an error in the outcome TXT file:
 
ERROR: flxActCommonHandleOpen - (50003,71000,1)

Cause

Error -158 essentially means that user cannot open Trusted Storage. Either the files are missing, have been corrupted\altered somehow,or user no longer has access rights to them.

Resolution

UPDATED: October 12, 2015
There are some things to check on the customers machine:

1.
Please see if Anti-virus on the system has them flagged or locked out as well.

2.
The trusted Storage files can be found in one of these two places depending on OS:
XP:
C:\Documents and Settings\All Users\Application Data\FLEXnet

Win7: C:\ProgramData\FLEXnet

Please check if any file is available in this folder, e.g. the license file <unisw20_004e4200_tsf.data> has been created successfully.

3. Start the Flexnet Licensing service manually. This should be by default not started and set to manual start. Go to Run > services.msc > and search for the Flexnet Licensing Service on the machine.  Start this service manually and then try to start MapInfo again.