VERIFIED SOLUTION i

MapInfo Professional 12.0 on Windows XP 64 throws msvcr110.dll error at startup

Issue


MapInfo Professional 12.0 on Windows XP 64 throws msvcr110.dll error at startup.

Cause

MapInfo Professional requires .NET and C++ components that in turn require Windows XP to be at Windows Service Pack 3.
But there is NO Windows Service Pack 3 for Windows XP 64-bit.

Note: this is a workaround - MapInfo Professional 12.0 is NOT tested and therefore not supported on Windows XP 64-bit.

Resolution

UPDATED: February 4, 2015

1) Make sure you're logged in with Administrator credentials and then use Windows Update to download and install all available Windows updates and reboot if indicated.

2) Go to
http://www.microsoft.com/en-us/download/details.aspx?id=32
and download and install the Imaging component.

3) Re-boot and then try launching MapInfo Professional....



Note: this is a workaround - MapInfo Professional 12.0 is NOT tested and therefore not supported on Windows XP 64-bit.
Environment Details